Tips: Building COBOL projects

Here are some tips on handling projects and building COBOL applications in the Eclipse IDE.

Add files to a project File > Import.
Build automatically Project > Build Automatically. With this set, whenever a resource changes, an incremental build starts and all resources modified since the last build are rebuilt.
Build settings and build types Project > Properties > Micro Focus > Project Settings and Project > Properties > Micro Focus > Build Configurations > COBOL. The currently active build configuration overrides the project language settings. You can create multiple build configurations for different build scenarios and swap between them.
COBOL settings Project > Properties > Micro Focus > Project Settings. Use this to set the dialect, character set, source format, and directives for the whole project. You can override these for an individual file by right-clicking the file in the COBOL Explorer or Team Developer Tree view and clicking Properties > COBOL Settings.
Content type Window > Preferences > General > Content Types. Use this to associate a file extension with the content type of a COBOL file, to colorize it in the editor, background parse it and compile it, if appropriate to the type of file.
Copybook paths Project > Properties > Micro Focus > Build Configuration > Build Paths > Dependency Paths. The search order here takes precedence over the COBCPY environment variable setting. To add copybook paths to this list, specify the paths as linked resources.
Tip: In order to increase the speed of indexing and background parsing, we recommend you deselect paths that don't contain copybooks.
Linked resources Linked resources enable you to link to sources rather than including them in the project. They show in the project in the COBOL Explorer and Team Developer Tree view as file icons decorated with a square with an arrow link.
Run-time Environment Settings Project > Properties > Micro Focus > Run-time Configuration. From here you can set a range of environment settings, including run-time switches and environment variables.
Stop a build in progress Click the red square, Terminate in the Progress view. To turn on this view, click Window > Show View > Other > General > Progress.
Pre and Post build events Configure these within the Build Configuration wizard. You can use then, for example, to set build environments and prerequisite, cleanup tasks and deploying build artifacts. You can specify shell scripts and single commands within the dialog box. Single commands should be placed on separate lines.
Delete build artifacts when project settings change By default, Eclipse is configured to always delete the build artifacts when the project settings change. You can change this behaviour from Window > Preferences > Micro Focus > Builder and change the settings for the Delete build artifacts when project settings change preference. The IDE then displays a notification when changes are made that would normally trigger artifacts to be deleted.
Improve performance and avoid running out of memory If a large amount of data is output to the build console, you can get memory-related errors or slow builds. You can limit the size of the console buffer to help avoid these problems. To do this, right-click in the build console and select Preferences > Limit console output and enter a number of characters.

You can also click the Clear Console button in the build console to free up memory during the build.