Create a Project

Walks you through the process of creating an Enterprise Developer project for the ScheduleDemo application and its service interface.
Restriction: This topic applies to Windows environments (local development) only.

Create the ProgramREST Project

Create a project for your service interface, and add files to the project.

  1. Start Enterprise Developer.

    If this is the first time you start the application, you see the Welcome page in Eclipse. Click Open Team Developer Perspective which is the default perspective for the product.

    If you have already started Eclipse, click Window > Show View > Team Developer Tree View.

  2. From the maim menu in Eclipse, click File > New > Other.

    This opens the New dialog dox.

  3. Expand Micro Focus COBOL folder, and then click COBOL Project.
  4. Click Next.

    This opens the New COBOL Project dialog box.

  5. In the Project name field, type ProgramREST.
  6. If not already checked, check Use default location; then click Finish.

    The Team Developer Tree view now shows the ProgramREST project.

  7. From the Team Developer Tree view, right-click the ProgramREST project and click Import from the context menu.
  8. Expand General; then double-click File System.
  9. Click the Browse button that corresponds to the From directory field, and browse to the %PUBLIC%\Documents\Micro Focus\Enterprise Developer\Samples\Interface Mapping Toolkit\ServiceInterfaces\ScheduleDemo directory; then click OK.
  10. In the left pane, check ScheduleDemo to select all files listed in both panes.
  11. In the right pane, uncheck Readme-Ec.xml and Readme.xml. These files are used by the Samples Browser.
  12. Click Finish.

    Enterprise Developer adds the files and builds the project automatically.

Set the COBOL Build Configuration

This IMTK project requires the build action to produce a dynamic link library (.dll) file for the schedule program. To ensure this behavior:

  1. In the Team Developer Tree View, right-click the ProgramREST project; then select Properties from the context menu.
  2. Expand Micro Focus > Build Configurations; then click COBOL.
  3. From the Target Type drop-down list, select All Native Library Files; then click OK.