Create a Project

Walks you through the process of creating an Enterprise Developer project for the BookDemo application and its service interface.
Restriction: This topic applies to Windows environments (local development) only.

Create the ProgramEJB Project

Create a project for your service interface, and add files to the project:

  1. Start Enterprise Developer.

    If this is the first time you start the application, you see the Welcome page in Eclipse. Click Open Team Developer Perspective which is the default perspective for the product.

    If you have already started Eclipse, click Window > Show View > Team Developer Tree view.

  2. From the Eclipse main menu, click File > New > Other.

    This opens the New dialog dox.

  3. Expand Micro Focus COBOL folder, and then click COBOL Project.
  4. Click Next.

    This opens the New COBOL Project dialog box.

  5. In the Project name field, type ProgramEJB.
  6. Check Use default location, then click Finish.

    The Team Developer Tree view now shows the ProgramEJB project.

  7. From the Team Developer Tree view, right-click the ProgramEJB project and select Import from the context menu.

    This opens the Import dialog box.

  8. Expand General and click File System.
  9. Click Next.
  10. Click the Browse button that corresponds to the From directory field, and browse to the %PUBLIC%\Documents\Micro Focus\Enterprise Developer\Samples\Interface Mapping Toolkit\ServiceInterfaces\BookDemo directory.
  11. Click OK.
  12. On the list of files, check the following:
    • book.cbl
    • book-rec.cpy
    • bookfile.dat
    • bookfile.idx
  13. Click Finish.

    This adds the files to the project and builds the project automatically.

Set the COBOL Build Configuration

This IMTK project requires the build action to produce a dynamic link library (.dll) file for the book program. To ensure this behavior:

  1. In the Team Developer Tree view, right-click the ProgramEJB project; then select Properties from the context menu.
  2. Expand Micro Focus > Build Configurations, then click COBOL.
  3. From the Target Type list, select All Native Library Files, then click OK.