Importing Existing COBOL Code into Enterprise Developer

Enterprise Developer includes a Net Express Project Import Wizard that converts Net Express projects into Enterprise Developer projects and imports the COBOL source code into the IDE.

To import Net Express projects

The Net Express project format is not the same as the project format in Enterprise Developer for Eclipse so it is not possible to edit Net Express projects in Enterprise Developer directly.

You can use the Import and Convert Net Express Projects wizard to convert existing Net Express projects into Eclipse projects, and to import the COBOL source into the IDE. Click File > Import > Micro Focus > Convert NetExpress Projects. The wizard analyzes your Net Express project, converts it to the appropriate project type and sets Compiler directives as needed.

To import files into an existing project

In Eclipse, you import files into your project using File > Import. This automatically adds to the project all files from the project directory, the subdirectories and from any linked directories. To prevent a file from being compiled, right-click the file and click Build Action > Ignore.

To scan files and set Compiler directives

After importing your existing sources into a project in the new IDE, you need to set the required Compiler directives.

In Eclipse, to set Compiler directives on COBOL files, use the file properties, or the Determine Directives command from the context menu for the files in COBOL Explorer. This triggers file scanning and sets directives as specified in Window > Preferences > Micro Focus > COBOL > Directives Determination