Information We Need

However you contact us, please try to include the information below, if you have it. The more information you can give, the better Micro Focus SupportLine can help you. But if you don't know all the answers, or you think some are irrelevant to your problem, please give whatever information you have.

On Windows, if you are reporting a protection violation you might be asked to provide a dump ( .dmp) file. To produce a dump file you use the Unexpected Error dialog box that is displayed when a protection violation occurs. Unless requested by Micro Focus SupportLine, leave the dump setting as Normal (recommended), click Dump, then specify a location and name for the dump file. Once the dump file has been written you can email it to Micro Focus SupportLine.

Alternatively, you might be asked to provide a log file created by the Consolidated Tracing Facility (CTF) - a tracing infrastructure that enables you to quickly and easily produce diagnostic information detailing the operation of a number of Micro Focus software components.

On Windows, you can use the Micro Focus SupportLine Support Scan Utility, MFSupportInfo, to create either:

MFSupportInfo.exe is stored in <install-dir>\bin.

To run MFSupportInfo:

  1. Start a 32-bit Enterprise Developer command prompt.
  2. Enter MFSupportinfo at the command prompt to start the utility.
  3. Create a .log file or a .zip archive as follows:
    1. To create a .log file, click File > Save.

      This prompts to save the .log file, MFSupportInfo_Log_MachineName_YYYY-MM-DD_HH-MM-SS.log, in the %temp% directory.

    2. To create a .zip archive, click Tools > Create Zip Package.

      This creates a .zip archive,, in the %temp% directory.

  4. Send the diagnostic information to your Micro Focus SupportLine representative:

    The following requires an Internet connection and an Email client:

    1. Click Tools > Email Log to SupportLine to open the Email Log dialog box.
    2. Fill in the required fields and click Send.

    If the machine is not connected to the Internet or if there are no Email clients installed, copy either the .log file or the .zip archive to a machine that is connected to the Internet. Use your Email client to email the files to Micro Focus SupportLine at together with the Support Incident (SI) number, if available, and any additional details that might be useful to diagnose the issues that you are experiencing.

On UNIX, you can use the Micro Focus UNIX Support Scan Utility, mfsupport, to create a log file that contains the details about your environment, product, and settings. The mfsupport script is stored in $COBDIR/bin.

To run mfsupport:

  1. Start a UNIX shell.
  2. Set COBDIR to the product with issues.
  3. Execute mfsupport from a directory where you have write permissions.

    This creates a log file, mfpoll.txt, in that directory.

  4. When the script finishes, send the mfpoll.txt file to your Micro Focus SupportLine representative.

If COBDIR is set to a location that does not contain etc/cobver, the script outputs the contents of /opt/microfocus/logs/MicroFocusProductRegistry.dat which keeps a list of the installed Micro Focus products.

If COBDIR is set to a location that does not contain etc/cobver or COBDIR is not set, mfsupport gives you the option to search your machine for possible product locations. Note that the search can take some time if you have a large amount of disc storage and files.