Starting the Eclipse Integrated Development Environment (IDE)

  1. To start the Eclipse IDE, click Start > All Programs > Micro Focus Enterprise Developer > Enterprise Developer for Eclipse.

    This opens the Workspace Launcher which enables you to choose a location for Eclipse to store your projects.

  2. Specify C:\MFETDUSER\BankDemo\Projects\Eclipse in the Workspace field and click OK.

    If this is the first time you start Enterprise Developer, you are presented with the Eclipse Welcome page. Click Open Team Developer Perspective to close the Welcome page and see the main Eclipse window.

    If the Welcome page is not opened, click Window > Perspective > Open Perspective > Other, select the Team Developer (default) and click OK.

    The views you see open in Eclipse and their layout depend on whether you have used Eclipse before. You can move, resize and minimize views which is why they might not look exactly as described here. If this is the first time you have used Eclipse, you should see the following views in the IDE, although most of the views are currently empty:

    • The Application Explorer view in the upper left part of the IDE gives a logical view of your applications. You are going to use the Application Explorer view most of the time. This tree view should already display an Enterprise Developer system entry. If not, right-click in this view, select Add System(s) and then select ED System and click OK. This view now displays a system entry used to support the standard Enterprise Developer projects. Expand this system entry and an application entry named Enterprise Development Projects is displayed. Right-click this application entry and select Load Application. If you are using this Eclipse workspace for the first time, there are no projects associated with this application.
    • The Properties, Outline, and Program Outline tabbed views in the bottom left part of the IDE provide more information about selected tree or table entries, and outline information on various types in your sources when you start editing COBOL or PL/I programs or JCL.
    • A series of tabbed views in the bottom right part of the IDE (Table Results view, Error Feedback view, Jobs view, File Mappings view, Console, Problems, Tasks) show for example sources in a table structure, the results of compiling and tasks.
    • The IDE provides a Server Explorer view, where you can view the underlying execution environment. This view is displayed as a tab in the upper left part of the IDE.
    • The Filter Definitions view in the upper right part of the IDE is used to manage search criteria within a loaded application.
    • The Remote Systems view is used to connect to the mainframe system z/OS and provides access to all mainframe resources like MVS or USS files and MVS jobs. This view is displayed as a tab in the upper right part of the IDE.
    • The main activity window in the top middle part of the IDE, the Editor, is where you edit or debug the sources.
    • Apart from the Eclipse menus, there are a number of buttons on the toolbar, which vary depending on what you are currently doing with Eclipse.
  3. Experiment with resizing, minimizing and restoring the views.
  4. If you close a view, click Window > Show View > View Name to restore it.
  5. At any time, you can reset the complete layout of the Team Developer Perspective to its default using Window > Reset Perspective.