Create a Project

Walks you through the process of creating an Enterprise Developer project for the ScheduleDemo application and its service interface.
Restriction: This topic applies to Windows environments (local development) only.

Create the ProgramSOAP Project

Create a project for your service interface, and add files to the project.

  1. Start Enterprise Developer. The method used depends on your operating system. See Starting Enterprise Developer for details.

    If this is the first time you start the application, you see the Welcome page in Eclipse. Click Open Team Developer Perspective which is the default perspective for the product.

    If you have already started Eclipse, click Window > Show View > Team Developer Tree View.

    In the Team Developer Tree View, you should see the Enterprise Developer@Windowsn system. If the system is not shown, to load it:

    1. Right-click in the Team Developer Tree View and click Add System(s).
    2. In the Add System(s) dialog box, select ED System and click OK.
    3. Expand the top-level Enterprise Developer entry in the Team Developer Tree View .
    4. Right-click Enterprise Developer Projects; then click Load Application.
  2. From the main menu in Eclipse, click File > New > Other.

    This opens the New dialog dox.

  3. Expand the Micro Focus COBOL folder, and then click COBOL Project.
  4. Click Next.

    This opens the New COBOL Project dialog box.

  5. In the Project name field, type ProgramSOAP.
  6. Check Use default location; then click Finish.

    The Team Developer Tree View now shows the ProgramSOAP project under the Enterprise Developer@Windowsversion > Enterprise Development Projects node.

  7. From the Team Developer Tree View, right-click the ProgramSOAP project and select Import from the context menu.

    This opens the Import dialog box.

  8. Expand General and click File System.
  9. Click Next.
  10. Click the Browse button that corresponds to the From directory field, and browse to the %PUBLIC%\Documents\Micro Focus\Enterprise Developer\Samples\Interface Mapping Toolkit\ServiceInterfaces\ScheduleDemo directory.
  11. Click OK.
  12. On the list of files, check all files except the Readme XML files.
  13. Click Finish.

    This adds the files to the project and builds the project automatically.

Set the COBOL Build Configuration

This IMTK project requires the build action to produce a dynamic link library (.dll) file for the schedule program. To ensure this behavior:

  1. In the Team Developer Tree View, right-click the ProgramSOAP project; then select Properties from the context menu.
  2. Expand Micro Focus > Build Configurations; then click COBOL.
  3. From the Target Type drop-down list, select All Native Library Files; then click OK.