Creating a PL/I project

From the Team Developer perspective:

  1. Click File > New > Project, expand the Micro Focus PL/I node and choose either:
    • Mainframe PL/I Project, which enables you to use JCL, BMS, and macro files with your project.
    • PL/I Project, for development of console applications.

    Click Next. The New PL/I Project dialog box appears.

  2. In the Project Name field, type a descriptive name for the project.
  3. If you have created your own PL/I project templates, you can select one of them from the Select a project template box.
  4. Select the Use default location check box to use the workspace location select when you started Enterprise Developer for Eclipse as the location to store the project. Clear the Use default location check box and click Browse to use the Browse For Folder dialog box to select a different location to store the project.
  5. Click Finish to create the new project.

To add new files to a PL/I Project

From the Team Developer perspective:

  1. To create new files and add them to your project, right-click your project in the Team Developer Tree view, click New > File and choose your file type.

    When you add a PL/I source file, it is created with a .pli extension, but Enterprise Developer also handles files with a .pl1 extension as PL/I source.

  2. Double-click a file in Team Developer Tree view to open it for editing.

    The PL/I Editor displays different types of keywords in different colors, which you can change by selecting Window > Preferences, expanding the Micro Focus and PL/I nodes and clicking PL/I Syntax Coloring.

To import existing files into a PL/I project

  1. Click your project in the Team Developer Tree view.
  2. Click File > Import.
  3. In the Import wizard, expand General, click File System and click Next.
  4. Specify the path to the directory that contains your files in the From directory field.
  5. Select the files you want to import and click Finish.