System Requirements

GitCentric requires the following software for a successful installation.

Note: Other components may have their own prerequisites.
Supported Configuration
Operating System

For GitCentric server:

  • Linux 2.6 or later.
  • SUSE 10 SP2 or later.

Compatible Ubuntu versions are 10.10 and later, RedHat 6.2 and later.

Other versions can be supported, but they have not been certified.

Web browsers can be run from any platform.


GitCentric is supported on these browsers:

  • Google Chrome (latest).
  • Mozilla Firefox (latest).
  • Internet Explorer 9 and later.
  • Microsoft Edge (the default browser in Microsoft Windows 10 and Microsoft Windows 10 Mobile).
Java 1.6 or later.

The AccuRev installation installs AccuRev at <ac_home>/jre. You may need to update your $PATH to point to this.


Version 5.6 or later.

Note: AccuRev installations have their own prerequisites such as Perl for running triggers.)