Publishing Requirements to StarTeam

The Publisher to StarTeam addin enables you to export Caliber requirements to StarTeam. Once the requirements are in StarTeam, you can view them, but not edit them. An ID string that identifies the requirement in Caliber is stored in a field in StarTeam. The default is to use the External Reference field in StarTeam.

An administrator periodically publishes requirements to StarTeam to update whatever changes have been made to the requirements in Caliber.

Publishing Caliber requirements to StarTeam involves the following steps:

  1. Enabling StarTeam integration in Caliber if you want to use Publisher to StarTeam from the Caliber Author.
  2. Running the Publisher to StarTeam wizard.
  3. Specifying the Caliber properties, which include the Caliber server and log-in information, and the source project and baseline.
  4. Selecting the Caliber requirements to publish to StarTeam.
  5. Specifying the StarTeam properties, which include the StarTeam server and log-in information, and the target project, view, and folder.
  6. Mapping the Caliber properties (attributes and UDAs ) to StarTeam properties (fields and custom fields).
  7. Saving your configuration to a property file for future use.
  8. Publishing the Caliber requirements to StarTeam.
Note: The StarTeam integration must be enabled in Caliber for a project before you can access Publisher to StarTeam from the Caliber Author menu or toolbar. However, you do not need to enable the StarTeam integration in Caliber if you only want to run Publisher to StarTeam from the Start menu.

To enable the StarTeam integration in Caliber

  1. In Caliber Administrator, choose View > Projects .
  2. Select the project for which you want to enable the StarTeam integration.
  3. Click the External Traceability tab.
  4. In the Disabled list , select StarTeam and click the Left Arrow button.

    StarTeam moves to the Enabled list.

  5. Select StarTeam and click Edit to open the Edit Integration dialog box.
  6. Click Modify to modify the configuration file.

    Click Import to import the existing .ini file.

  7. Click OK to exit the Edit Integration dialog box and save the edits.
  8. Choose File > Save Changes to save the External Traceability settings.
    Note: To cancel the External Traceability changes, choose Edit > Cancel Changes before you save the changes.