Debugging COBOL in Eclipse

Here are some tips and tricks on debugging COBOL applications in the Eclipse IDE.

Breakpoint - setting Run > Toggle Breakpoint or double-click in the left margin.
Data item values To display a data item's value, you can hover over it, or alternatively right-click it and click Inspect COBOL. See Variables view .
Debug See To debug a COBOL program
Debug configurations Run > Debug Configurations. You can have multiple debug configurations and swap between them. These settings here override the project run-time settings. See Debug configurations
Debug view This view gives a dynamic view of all the threads. For each thread, this view shows the call/perform stack, showing where the current statement was called from or performed from, and where previous calls and performs came from. You can move the execution point, by right-clicking a thread and choosing an option from the menu. The Debug view is shown by default in the Debug perspective at the top left. You can show it by clicking Window > Show View > Debug.
Expressions view Shows the data items and the variables which you have chosen to monitor. You can add a data item to this view by selecting it in the code view, right-clicking and choosing Inspect COBOL and then choosing Add to Expressions. The Expressions view is shown by default in the Debug perspective at the top right. You can show it by clicking Window > Show View > Expressions. You can also change the value of a data item by right-clicking it in Expressions view and choosing Change Value.
Main program to debug Run > Debug. On the General tab, specify the main program file. To create a debug configuration
Reset execution Moves the execution point to the cursor position. The shortcut key is Alt+F12.
Preferences Window > Preferences > Micro Focus COBOL > Debug. Among other things, you can choose to display hexadecimal and byte values of data items.
Stop debugging Run > Terminate. You can also click the red square at the top. See To debug a COBOL program
Variables view Shows the data items in the previous and current statements, together with the data items' values. Changed items are highlighted in yellow. You can change values here. The Variables view is shown by default in the Debug perspective at the top right. You can show it by clicking Window > Show View > Variables.
Watchpoint-setting Run > Toggle Watchpoint or double-click in the left margin.