Building COBOL Remote Projects

Add files to a project File > Import.
Build automatically Project > Build automatically. With this set, whenever a resource changes, an incremental build starts and all resources modified since the last build are rebuilt.
Build settings and build types Project > Properties > Micro Focus COBOL > Project Languages Settings and Project > Properties > Micro Focus COBOL > Build Configuration. The currently active build configuration overrides the project language settings. You can create mulltiple build configurations for different build scenarios and swap between them. To build a COBOL project.
Pre and Post build events

Configure these within the Build Configuration wizard. You can use then, for example, to set build environments and prerequisite, cleanup tasks and deploying build artifacts.

You can specify shell scripts and single commands within the dialog box. Single commands should be placed on separate lines.

COBOL settings Project > Properties > Micro Focus COBOL > Language settings. Use this to set the dialect, character set and directives for the whole project. You can override these for an individual file by right-clicking the file in the Navigator view and clicking Properties > COBOL Settings.
Content type Window > Preferences > General > Content Types. Use this to associate a file extension with the content type of a COBOL file, to colorize it in the editor, background parse it and compile it, if appropriate to the type of file.
Copybook paths Project > Properties > Micro Focus COBOL > Copybook Paths. The search order here takes precedence over the COBCPY environment variable setting. To add copybook paths to this list, specify the paths as linked resources.
Copybooks ignored A project can contain COBOL files that don't require compiling, such as copybooks. To specify the files to avoid compiling, right-click the folders or individual files in Navigator and click Build action > Ignore.
Dependencies Dependency information is held for each project, and by default, it is updated when the project is built. This can slow down the build. To speed up the build, you can update the dependency information manually before building the project. To do this, right-click the project or file and click Update All Dependencies or Update Dependencies.
Linked resources Linked resources enable you to link to sources rather than including them in the project. They show in the project in the Navigator. They are distinguished with file icons decorated with a square with an arrow link.See To link to copybooks or sources outside the project.
Stop a build in progress Click the red square, Terminate in the Progress view. To turn on this view, click Window > Show View > Other > General > Progress.